Cannot backtest combo

Bug info:
This combo bot and most others I tried today won’t backtest. Iv restarted browser and computer, same problem.

  • Bot URL → Gainium app
  • [Optional] Steps to reproduce → backtest 2023, 1m timeframe
  • Expected result →

Hey @roni.chua, is there any restriction in your location for the exchange you are requesting data? If so, that may be the problem. For example Binance won’t serve candle data to users in the US, so to be able to do a backtest you would need to use a VPN or server-side backtesting.

Gday Ares, I’m in Australia. No restrictions that I know of mate. I take it was no problem for you to test?

This problem has only occurred in the last few days. I was testing a week ago and it was normal.

I have now tried VPN in Norway and Czech Republic and getting same problem. Also, removed all extensions on my Chrome browser.

It’s working fine for me 1m 2023.

I would suggest to try on another browser or another device. If you used VPN make sure your IP was properly hidden.

Ok, I’ve been able to trigger the problem. It does not have anything to do with VPN.

As soon as I get the red error message as shown here in the DCA minigrid level limit, even after I correct it, the bot will not backtest. It backtests initially if I have it within the limit.

I noticed if it’s a saved setting above the limit the backtest will go ahead. But as soon as I change it to a value beyond the limit, it will no longer backtest.

BTW, the limit is 3, but the red error message wants it less than 3 (not 3 - a contradiction to what is acceptable).

image

It’s probably a restriction your programmer has to prevent a backtest if grid levels are more than 3, that got triggered and not deactivated when corrected.

Ok thanks for reporting we will fix that

1 Like

I still cannot reproduce. I triggered the errors and no problem backtesting.

Can you try this:

  1. Hard refresh (CMD+SHIFT+R)
  2. Clear cookies
  3. Test it on Chrome

I’ve just tried your latest suggestions, yeah, but nah. It did not make any difference.

I use a PC so shift + refresh for a fresh refresh. I also deleted cookies for 4 weeks.

If I don’t trigger the red error message it backtests. But if I do, I cannot, even after correction.

This problem only happened after the update that provided the error messages about too many mini grid levels. I never had this problem. Now I cannot backtest the combo bot at all, unless it is an existing configuration. Any changes will make it ‘un-backtestable’.

Here you can see it backtesting without the red error message:

Try CTRL+F5 and let me know.

After CTRL+F5 the red message no longer appears and the limit was raised from 5 to 16… HOWEVER, same problem - it won’t backtest still.

tried again this morning after reboot, clean chrome browser, and cntrl+f5 but it’s still the same and won’t backtest after changes made to the settings that are within the ranges.

Since it is working for me I can only say that your issue must be in your browser, your machine or your location. Until we don’t know which one is the problem there is nothing we can do. Try Firefox, another computer or phone, and a VPN

ok. Iv just tried mozilla and it’s not working either. same exact problem. i dont’ think it’s a vpn problem as i am able to backtest your trading bots. the other issue im thinknig is CPU problem. i will try another computer.

after saving that bot into another, i was able to backtest the new bot, provided i kept within the new limit on minigrid number.